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Spread Sheet Basics 
(MS-Excel) 

 

Objectives: 

To discuss about the basics of Spread Sheet and various features of Microsoft Office-Excel 

software such as: 

 Spreadsheets terminologies: worksheet, cell, column and row, range, formula, function and 

cell pointer.  

 How to enter, change, delete to the cells or sheet and apply data validation 

 Sorting and filtering data using auto-filter, advance filter  

 Working with functions and formulas, nesting functions and macros  

 Formatting - Auto formatting and conditional formatting 

 Use chart wizard, pivot tables and pivot charts, and goal seek 

 Working with Add-ins, and protecting a worksheet/workbook 

 

1. Introduction 

After word processing, spreadsheets are probably the most important and widespread computer 

application. Spreadsheets can handle all of the financial calculations for a large business, they 

can be used to work with statistics and to calculate probability or other statistical information. A 

spreadsheet consists of cells arranged in rows and columns. Each cell can hold text, a number, or 
a mathematical formula.  

Spreadsheet is quite useful in entering, editing, analyzing and storing data. Excel is one of the 

most widely used spreadsheet applications. It is a part of Microsoft Office suite. Arithmetic 

operations with numerical data such as addition, subtraction, multiplication and division can be 

done using Excel. We can sort numbers/characters according to some given criteria (like 

ascending, descending etc.) and use simple financial, mathematical and statistical formulas.   

2. Spreadsheet Terminologies 

2.1 Worksheet - A worksheet or sheet is a single page in a file created with an electronic 

spreadsheet program such as Excel or Google Spreadsheets. A worksheet is used to store, 

manipulate, and display data. Each worksheet has 16,384 columns and 1,048,576 rows (cannot 

be changed) for a total of 17,179,869,184 cells. By default, each new file contains only one 

worksheet. 

2.2 Cell - The most fundamental unit of spreadsheets is the cell (a box for holding 

information), which is the intersection of a column and a row. The cells are identified by a cross 



section of letters and numbers. The top row contains letters across the top of worksheet. There is 

a column on the left that contains numbers. The combination of the letter and number provides a 

cross reference of a cell's location. For example, A1 specifies the cell in column A and row 1. A 

single worksheet contains over 17 billion cells.  

2.3 Column and Row - Each worksheet is divided into columns and rows. Columns are 

vertical; rows are horizontal. Columns are labelled, left-to-right, with letters (A, B, C …. Z, AA, 

AB … AZ, BA, BB ……. ZZ, AAA, AAB …..).  We can resize, hide and unhide the rows or 

columns by selecting a specified cell range. 

2.4 Data - Data is information that is stored in the individual cells of a worksheet or a 

spreadsheet program. Only one piece of data is stored in each cell. In addition to being stored in 

the spreadsheet, the data can be used in calculations, displayed in graphs, or sorted and filtered to 

find specific information. There are three types of data in Excel: values, labels, and dates/times. 

Labels (text) are descriptive pieces of information, such as names, months, or other identifying 

statistics, and they usually include alphabetic characters. 

2.5 Range - A group of cells. Ranges are often referenced for formulas, printing, and for 

designating a group of information to be copied or cut. Ranges can be selected by dragging 

(sometimes referred to as painting) over the cells. 

2.6 Formula - Used to instruct Excel to perform a calculation of numbers entered in the 

cells. There are hundreds of functions in Excel like sum, average, product, and count. All 

formulas begin with the equal sign (=).  For example, a formula in a cell can be as simple as 

=2+2 or =A5+D5. To add multiple numbers, select all the numbers in cells and click on 

"AutoSum".  

 
2.7 Function - A function is a preset formula.  Like formulas, functions in Excel begin with 

the equal sign ( = ) followed by the function’s name and its arguments.  The function name tells 

Excel what calculation to perform. The arguments are contained inside round brackets and tell 

Excel what data or other information to use in the calculations. 

For example, the SUM function is one of the most commonly used functions in Excel. It is used 

to add together the data in selected cells. The SUM function is written as –  

http://spreadsheets.about.com/od/f/g/formula_defined.htm
http://spreadsheets.about.com/od/a/g/argument_def.htm
http://spreadsheets.about.com/od/d/g/data_definition.htm
http://spreadsheets.about.com/od/c/g/cell_definition.htm


= SUM ( D1 : D7 ) as shown in the figure below. 

 
Here the function adds the contents of cells D1 to D7 and stores the answer in cell D8. 

2.8 Cell Pointer - The cell pointer is similar to the word processing’s insertion point. It 

selects or marks the current cell (where the next activity is going to take place). 

3. Starting with Microsoft Excel 2007 

This is the window of Microsoft Excel 2007.  

 
4. Basic Features 

The most common things in a spreadsheet that allow adding, deleting, renaming, sorting, 

filtering, inserting, copying, and pasting the cells containing data from one place to other in the 

same worksheet or to another sheets or workbook. In Microsoft Excel, if we right-click a 

worksheet, all the shortcut menus will be displayed as shown in the figure below.   



 
4.1 Insert - With the short key we can simply insert cells and a row/column anywhere in the 

worksheet. 

4.2 Delete or erase - Delete option can be used for many purposes, either to permanently 

remove a row/column or worksheet from the workbook. 

4.3 Clear Contents - Right clicking on the selected data can be deleted using the option. 

4.4 Hyperlink -We can link one file to another file or page with the use of Excel. 

4.5 Insert Comment - There are two ways to insert comment for the cells in the worksheet. 

We can directly add comment to a cell by right clicking on the particular cell or we can 

add/edit/delete comment from the Review Tab as shown below. 

 

 
4.6 Sort and Filter - Excel spreadsheets help us make sense of large amounts of data. With these 

options, we can sort our data either ascending or descending order and filter the data so that 

repetitions will be removed. Suppose we have a list of hundreds of records including dates, ages, names, 

cities, and more. We can quickly organize the data to best suit our needs using Excel’s sort and filter 

features. We can sort an entire worksheet or a range or table of data. Sorting can be done one or more 

columns by using Custom Short as shown in the figure below. 

 



 

 
 

Using Basic Auto Filter to filter data is a quick and easy way to find and work with a subset of data in a 

range of cells or table as shown in the figure below. Excel gives both option that we can either re-apply a 

filter to get up-to-date results, or clear a filter to redisplay all of the data. 

 

 
 

The Advanced Filter is used to perform more complex filtering than the basic Excel Auto Filter. Instead 

of filtering by fixed values or simple criteria, the advanced filter depends on user-defined criteria, that 

can be applied to several columns of data simultaneously. These criteria are specified on the same 

spreadsheet as the range to be filtered, rather than in a drop-down menu. 

 

In order to perform an Excel advanced filter, we need to specify a list_range and 

a criteria_range by clicking advanced filter button. These ranges both specify ranges of cells on 

the working spreadsheet. They are defined as follows: 

 list_range - The range of cells that you want to filter. This range should include 
headers at the top of each column. 

 criteria_range - A range of cells (generally positioned above or below the list_range), 
in which the filtering criteria are specified. 

 

The criteria_range should be headed by headers that match the list_range headings. The criteria for the 

http://www.excelfunctions.net/ExcelFilter.html


corresponding rows in the list_range should be listed under each of these headings as shown in figure 

below. For example: 

 

 
 

4.7 Charts - With charts, we can visually summarize numerical information and display any 

trends or patterns that we want to present. Charts and graphs can help make our data more 

meaningful and easier to understand. Different types of chat are used in excel such as column, 

bar, line and pie. For example, to create a column chart, execute the following steps. 
1. In the example, select the range A1:B5. 

2. Under Insert tab, in the Charts group choose Column, and select Clustered Column. 

 



  
 

Although the Chart Tools ribbon is full of cool things we can do to our chart, sometimes we might want 

more control. On right clicking the chart following options will be displayed and using this, we can 

change the chart type, select the appropriate data sources, move the chart to the next sheet and format 

the chart area (for example, data series, axes, or titles). 

 

 
 



4.7 Add Database - We can add database from other sources with data feature using the 

Data tab menu. 

 
4. Advanced Features 

5.1 Data Validations - Data validation is a  significant feature of Excel that can be used to 

define restrictions on what data can or should be entered in a cell. Data validation options are 

located in the Data Tools group. For example, we can limit types of departments to Sales, 

Finance, R&D, and IT. Similarly, we can create a list of values from a range of cells elsewhere in 

the worksheet.   

 



  
We can configure data validation to prevent users from entering data that is not valid. When 

users enter invalid data it will warn them when they try to type it in the cell. We can also provide 

messages to define what input we expect for the cell, and instructions to help users correct any 

errors. 

5.2 Nesting functions 

Some Excel users, especially new comers, may think that we can only use one Excel function at 

a time in a cell. But the fact is that we can join as many functions as necessary in a cell. We can 

even nest multiple functions within each other to achieve a certain formula. When we do, we are 

using the results of the nested functions as arguments— pieces of data the first function needs to 

run properly. You can always tell when a function is nested because it's inside parentheses.  

Example 1: The IF function uses nested AVERAGE and SUM functions as arguments. 

=IF(AVERAGE(F2:F5)>50,SUM(G2:G5),0) 

You can read this formula from left to right. IF the average value of cells F2 to F5 is greater than 50, then 

SUM the values in cells G2 through G5. Otherwise, return 0. 

Here is an example of an IF statement for the "value-if-false" parameter: 

Example 2: A common example of nested IF functions is when grades or awards are based upon 

a numeric scale. Formulas with nested IF functions are entered into column C cells to display 

each student's letter grade based upon the numeric grade entered into column B. 

 

 

Here is the function in cell D4 for Mr. Cole: 

=IF(B4>89,"A",IF(B4>79,"B",IF(B4>69,"C",I

F(B4>59,"D","F")))) 

 

5.2 Macros - Macros are used for recording events for further use. Macros are sets of 

instructions based on actions that we can record while we work in a spreadsheet. After recording 

a macro, we can use it again as the need arises.  

https://support.office.com/en-US/article/IF-function-69aed7c9-4e8a-4755-a9bc-aa8bbff73be2
https://support.office.com/en-US/article/AVERAGE-047bac88-d466-426c-a32b-8f33eb960cf6
https://support.office.com/en-US/article/SUM-043e1c7d-7726-4e80-8f32-07b23e057f89


Macro is available under the View as well as Developer tab. If the Developer tab is not available 

in the menu bar, do the following to display: 

Click the Microsoft Office Button , and then click Excel Options. 

In the Popular category, under Top options for working with Excel, select the Show Developer 

tab in the Ribbon check box, and then click OK. It will be shown as below.  

 
For example, we have a table of Employee list and we can do subtotal of salaries according to 

department. All the process will be recorded by using Macro.  

 

Step 1 - Click on Record Macro, give the macro name and provide a shortcut key, then click 

OK. It will create a macro and start recording.  

 
 

Step 2 - Select the data range, click on the subtotal option under Data tab and then add subtotal to the 

necessary fields as shown below.  Once Excel completes the subtotal, stop the recording.  



 

 
 

Step 3 - To see the recorded macro, go to Macro and it will show the above process again. 

 



5.3 Auto formatting and Conditional formatting - These options are used to change the 

format of a cell dependent on the content of the cell, or a range of cells, or cells in the workbook. 

Conditional formatting helps users to quickly focus on important aspects of a spreadsheet or to 

highlight errors and to identify important patterns in data. 

 
Formatting a worksheet is not done just to make it look good. The choice of background color, 

font style and font size, plus other formatting options can make data easier to read and allow 

readers to easily pick out the most important information in the spreadsheet. 

Conditional formats can apply basic font and cell formatting such as number format, font colour 

and other font attributes, cell borders, cell fill colour and Highlight cell rules. In addition, there is 

a range of graphical conditional formats that helps with visualizing data by using icon sets, 

colour scales, or data bars.  

 
For example, we can choose for Excel to highlight cells that are greater than $300 and highlight 

cells that contain specific text.   



 
If we later decide that we don’t want our cells to be conditionally formatted, all we can clear the 

formatting. To do this, select the Conditional Formatting button and select Clear Rules. Then, 

select whether you want to clear the rules from only the selected cells or from the 

entire worksheet. 

 
5.4 Pivot Table - Pivot table is an extremely useful tool that makes it easy to tabulate and 

summarize data in the spreadsheets. First determine the fields that are necessary to answer this 

question, then drag-and-drop at the bottom of the field list and in the layout area. The pivot table 

doesn’t change our raw data, but rather creates a new view of it. While there are many more 

things we can do with pivot tables, pivot table are always connected with pivot charts. 

SELECTING THE DATA: Put the cursor anywhere in the data set (we don’t have to select it 

all), then go to the Insert menu and choose Pivot Table. Let us take a example: 

http://www.online-tech-tips.com/ms-office-tips/excel-conditional-formatting/


 
 

Using the above example, we will create a summarized report for Employee Name and  their 

salary amount. If we click on OK button we will get the following screen. This is a default 

setting in Excel that data with numbers will always appear on the right and all of the person data 

appears on the left side as rows. Once the report will be created, Pivot chart option will be 

displayed in the same screen. On clicking the pivot chart option, the chart along with a 

PivotChart Filter Pane will  be shown on the same screen, where we can adjust the chart: by 

filtering the data, Axis fields and Legend fields and sum values. 

 



5.4 Goal Seek 

The goal seek function, Excel’s what-if analysis tool set, allows us  to see how one data item in a 

formula impacts another. It is available under the Data Tab. In Goal Seek there will be three 

boxes to fill in. 

1. The first says "Set cell." Enter the cell address (or click on the cell) of the cell whose 

value you want to fix or set to a specific number (i.e. Profit cell). This cell must contain a 

formula or function. Otherwise it will not be linked to the cell you will be changing to 

obtain zero profit. 

2. The second says "To value." Enter the appropriate value you wish to see in that "Set" cell 

(i.e. 0 if you want the Profit to come out zero). 

3. The third says "By changing cell." Enter or click on the cell you want Goal Seek to 

change to obtain the zero profit. (i.e. milk price). This cell must not be a formula or 

function. Then click "okay." 

To get a better understanding of what the goal seek command actually does, assume the 

following cells. We will use Goal Seek to find a number to make the sum=100. 

L1 = 32 

L2 = 63 

A3 = SUM(L1:L2) which is showing 95 

In Goal Seek:   

 Set Cell: Click on L3 

 To Value: enter 100 

 By Changing Cell: click on L1 

The sum in L3 should now be 100, and A3 should have become 37 for that to happen. 

 
5.5 Protecting worksheet or workbook 

When we share a workbook with other users, we may want to protect data in specific worksheet 

or workbook elements to help prevent it from being changed. We can also specify a password 

that users must enter to modify specific, protected worksheet and workbook elements. In 

addition, We can prevent users from changing the structure of a worksheet.  

 Protect worksheet elements 
 



1. Select the worksheet that we want to protect. 
2. To unlock any cells or ranges that we want other users to be able to change, do the following: 

a. Select each cell or range that we want to unlock. 
b. On the Home tab, in the Cells group, click Format, and then click Format Cells. 

c. On the Protection tab, clear the Locked check box, and then click OK. 

 Protect workbook elements 

1. On the Review tab, in the Changes group, click Protect Workbook. 

 

2. Under Protect workbook, we can do one or more of the following: 



a. To protect the structure of a workbook, select the Structure check box. 

b. To keep workbook windows in the same size and position every time the workbook is 

opened, select the Windows check box. 



Similarly, we can Protect elements in a shared workbook and remove protection from a worksheet from 
the Review tab. 

Summary 

In the spreadsheets basics, we discussed different Spreadsheet Terminologies and basic as well as 

advanced used Excel features such as charts wizard, macros, data validation, pivot table, Sorting and 

filtering data using auto-filter, advance filter , nesting functions and protecting a worksheet/workbook. 

 

 

 

 


