
 

Word Processing 
PART II 

 

Objectives 

In Part I, we have discussed  different terminologies of Word processing and the basics features  Ms 

Word software. In this Part(II) we will discuss the most advance features in Microsoft Word (2007) such 

as: 

 Inserting tables, headers and footers, page numbers, hyperlink 

 Managing footnotes and endnotes, references and cross-references  

 Using word template,  table of contents, spell check, grammar and thesaurus, mail merge, and  

 Setting paragraphs and character styles 

 Recording macro 

Advance Features of MS Word 2007 

 

1. Working with Tables  

Inserting a table in a Microsoft Word document can be a lot easier than trying to insert text areas in a 

spreadsheet application like Excel. Creating tables of various sizes and styles in Word is a skill that can be 

useful when financial or numerical information and written text need to be presented in the same 

document. Word allows us to insert simple tables, pre-designed tables and complex, customizable tables 

in a document with little effort.  

 

 On the Insert tab, in the Tables group, click Table, and then click Insert Table.  

 Under Table size, enter the number of columns and rows.  

 Under AutoFit behaviour, choose options to adjust the table size. 

 

 



 

We can also insert an Excel spreadsheet or draw a table on the Word document. Apart from that MS 

Word provides inbuilt tables to be used in the document file.  

 

After inserting a table, the next step is design or customizing the Tables.   On selecting the table, the 

ribbon interface changes to the Design Ribbon under Table Tools, where we can use the built-in 

templates and other options for customizing. 

 

  
 

2. Headers and Footers  

Word includes many predesigned headers or footers that we can insert into our document. Or we can 

create a header or footer from scratch. The header or footer is inserted on every page of the document. 

   
 

 

 
 

 On the Insert tab, in the Header & Footer group, click Header or Footer. 

 Select and insert one of the built-in header or footer design to the Word document. 

 



 
 After inserting the Header and Footer, the next step is to design its looks. We can type text or 

insert graphics and other content by using the options in the Insert group on the Design tab, 

under the Header & Footer Tools tab. 

 

 
 

 Also we can select the Different First Page check box under, in the Options group, on 

the Design tab under Header & Footer Tools. 

 

3. Page Numbering 

If our document has multiple pages, we can display the page number on each page. Page numbers 

appear in either the header or the footer of each page. Microsoft Office Word 2007 has many 

preformatted page number designs, so that we can quickly insert headers or footers that display the 

page number and additional content, such as a graphic, the document title, the author's name, or the 

date. 

 

If we have already selected header or footer in our document, and we want to add page numbers 

without losing any information in that header or footer, use the Page field code.  

 

Click Insert → Quick Parts → Field → Field Names → Page 



 
 

And if we don’t have Header and Footer in our document then, 

 Click Insert → Page Number, click a location (such as Top of Page), and then pick a style. Word 

automatically numbers every page. 

    
 When we’re done, click Close Header and Footer, or double-click anywhere outside the header 

and footer area. 

    
 

4. Managing Footnotes and Endnotes 
 



Footnotes and endnotes are used in printed documents to explain, comment on, or provide references 

for text in a document. Footnotes can be used for detailed comments and endnotes for citation of 

sources. 

 Go to the References Tab in MS-Word 

 In the Footnotes group, click the Footnote or Endnote button. 

 

 
 In the Number format box, click one of the options and click on Insert button. By default, 

Word places footnotes at the end of each page and endnotes at the end of the document.  

Keyboard shortcuts: 

 To insert a subsequent footnote, press CTRL+ALT+F.  

 To insert a subsequent endnote, press CTRL+ALT+D. 

 

5. Managing References 

Word 2007 offers great tools for citing sources, creating a bibliography, and managing the sources.  The 
first step to creating a reference list and citations in a document is to choose the appropriate style that 
we will be using for formatting the citations and references. 
 
A. Style  

To choose a publishing style: 

 Click the References Tab on the Ribbon 

 Click the drop down box next to Style in the Citations & Bibliography Group 

 Choose the appropriate style 



 

B.  Citations 

To insert a citation in the text portion of our document: 

 Click the References Tab on the Ribbon 

 Click the Insert Citation Button on the Citations & Bibliography Group 

 If this is a new source, click New Source 

 If we have already created this source, it will in the drop down list and we can click on it 

 

 
 If we are creating a New Source, choose the type of source (book, article, etc.) 

 Complete the Create Source Form 

 If we need additional fields, be sure to click the Show All Bibliography Fields check box 

 Click OK 

 
 



C.  Placeholders 

Placeholders can be utilized when there is a reference to be cited, but we do not have all of the 

information on the source.  To insert a Placeholder: 

 Click Insert Citation 

 Click Add New Placeholder 

 
 

D. Manage Sources 

Once we have completed a document we may need to add or delete sources, modify existing 

sources, or complete the information for the placeholders. To Manage Sources: 

 Click the References Tab on the Ribbon 

 Click the Manage Sources Button on the Citations & Bibliography Group 

 From this menu we can Add, Delete, and Edit Sources (note, we can preview the source in the 

bottom pane of the window 



 
 

E. Bibliography 

To add a Bibliography to the document: 

 Place the cursor in the document where we want the bibliography 

 Click the References Tab on the Ribbon 

 Click the Bibliography Button on the Citations & Bibliography Group 

 Choose Insert Built-in Bibliography/Works Cited or Insert Bibliography 

 

 



6. Inserting Captions 

We can add captions to figures, equations, or other objects, and use those captions to create a table of 

the captioned items, for example, a table of figures or a table of equations. 

 

 Select the object (table, equation, figure,) that we want to add a caption to. 

 On the References tab, in the Captions group, click Insert Caption. 

 Click New Label, type the new label in the Label box, and then click OK. 

 Type any text, including punctuation that we want to appear after the label. 

 Select any one of options from Level Box. 

 Then click the Position dropdown box and select the position where the caption to be appeared 

in relation to the object (e.g., above or below it) 

 Add any text for the caption in the Caption field. 

 Click OK. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7. Forging Cross References 

A cross-reference refers to an item that appears in another location in a document. For example, we can 

mention in document and refer the reader to the figure's location elsewhere in the document.  

 

We can insert the cross references manually. However, this will quickly get unruly as our document 

grows. We would  need to go back and correct the cross references when our document is complete.  

Or, we can use Word’s Cross-reference feature. It will update the cross references automatically. We 

can also click on a Cross-reference in a document to be taken to a reference’s target. 

 

Simply follow these steps to use Word 2007’s Cross-reference feature: 

 Position the cursor where we would like to insert the cross reference' 

 Open the Insert tab 

 In the Links section, click Cross-reference 



 Select the type of item we would like to reference. For example, we can select headings, 

footnotes or numbered items. To reference figures or tables, we must use Word’s Caption feature 

 Other options in the dialog box will change automatically. The options will let us select from 

available items to reference. For example, we will see a list of headings or numbered items from 

which to choose 

 After making the selection, click Insert 

 Close the dialog box 

 

If we want to delete a cross reference, simply highlight cross reference and press the delete key. 

 
 
8. Word Templates 

If we frequently create a certain type of document, such as a monthly report, a sales forecast, or a 

presentation with a company logo, save it as a template so that we can use that as our starting point 

instead of recreating the file from scratch each time we need it.  

 To save a file as a template, click File > Save As. 

 For a basic template, click the template item in the Save as type list. In Word for example, 

click Word Template. 

 If the document contains macros, click Word Macro-Enabled Template. 

 Then enter a file name for the template and click on the Save button. 



 
   

9. Hyperlinks 

We can insert links in our Word document to pictures, music files, video files folders and even web 

pages. Our links can be pictures, text or any other object in our document. We can also create links to a 

blank email message or to other locations in the same document.  

 

Select the text or picture or a webpage that we want to display as the hyperlink. 

 On the Insert tab, in the Links group, click Hyperlink . 

 We can also right-click the text or picture and then click Hyperlink on the shortcut menu. 

 Click Existing File or Web Page under Link to, and then type the address that we want to link to 

in the Address box.  

 



10. Table of Contents  

The easiest way to create a table of contents is to use the built-in heading styles.  

1. Click where we want to insert the table of contents, usually at the beginning of a document. 

2. On the References tab, in the Table of Contents group, click Table of Contents, and then click 

the table of contents style that we want. 

 

If we already have a table of contents in our document, we can change the options. by inserting a new 

table of contents by using the Table of Contents dialog box. 

 



In the Table of Contents dialog box, do any of the following: 

 To change how many heading levels are displayed in the table of contents, enter the number 

that we want in the box next to Show levels, under General. 

 To change the overall look of table of contents, click a different format in the Formats list. We 

can see it like in the Print Preview and Web Preview areas. 

 To change the way heading levels are displayed in the table of contents, click Modify. In 

the Style dialog box, click the level that we want to change, and then click Modify. In the Modify 

Style dialog box, then change the font, the size, and the amount of indentation. 

If we added or removed headings or other table of contents entries in our document, we can quickly 

update the table of contents. 

11. Spell Check and Grammar 

Spell check is a software tool for correcting spelling. It is available in word processing programs, email 

programs, cell phones, and a variety of other applications, such as blogs and forums. 

 

In MS Word 2007 

 Go to the Review tab. 

 Click on the Spelling & Grammar command. 

 
 The Spelling and Grammar dialog box will open. For each error in our document, Word will try 

to offer one or more suggestions. We can select a suggestion and click Change to correct the 

error. 

 If no suggestions are given, we can manually type the correct spelling. 

 



12. Thesaurus 

A thesaurus is a dictionary of synonyms, words and phrases that mean the same thing as a particular 

word or phrase. Microsoft Word, and in more recent versions of Microsoft Office, other programs in the 

Office suite, come equipped with a thesaurus feature that enables us to look up both synonyms and 

antonyms, on selecting a particular word/phase. 

 

13. Mail Merge 

Mail Merge is a useful tool in Word processor that allows us to produce multiple letters, labels, 

envelopes, name tags  and more, using information stored in a list, database, or spreadsheet. Mail 

merge can be used for so much more than just producing mass mailings. Mail merge can be used to 

create any type of printed document, as well as electronically distributed documents and faxes.  

 

To use Mail Merge: 

 Select the Mailings on the Ribbon 

 Select the Start Mail Merge command 

 Select Step by Step Mail Merge Wizard 

 

 
 

The Mail Merge task pane appears on the right hand side of the Word document which guide us through 

the six main steps to complete a merge. We will have several decisions to make during the process. The 

following is an example of how to create a form letter and merge the letter with a data list. 

 

Step 1-3 

 Choose the type of document we want to create In this example, select Letters -Step 1 

 Click Next: Starting document to move to Step 2 

 Select Use the current document 

 Click Next: Select recipients to move to Step 3 

 Select the Type a new list button 

 Click Create to create a data source.  The New Address List dialog box appears 

 Click Customize in the dialog box.  The Customize Address List dialog box appears 

 Select any field we do not need, and click Delete 

 Click Yes to confirm that we want to delete the field 

 Continue to delete any unnecessary fields 



 Click Add The Add Field dialog box appears 

 Enter the new field name 

 Click OK 

 Continue to add any fields necessary 

 Click OK to close the Customize Address List dialog box 

 

 Enter the necessary data in the New Address List dialog box. 

 Click New Entry to enter another record. 

 Click Close when we have entered all of our data records. 

 Enter the file name we want to save the data list as. 

 Choose the location where we want to save the file. 

 Click Save. The Mail Merge Recipients dialog box appears and displays all of the data 

records in the list. 

 Confirm that the data list is correct, and click OK. 

 Click Next: Write your letter to move to Step 4. 

Steps 4-6 

 Write a letter in the current Word document, or use an open existing document. 

 To insert recipient data from the list: 

 Place the insertion point in the document where we want the information to appear. 

 Select Address block, Greeting line, or Electronic postage from the task pane. A dialog box 

with options will appear based on our selection. 

 



OR 

 Select More Items. The Insert Merge Field dialog box will appear. 

 Select the field we want to insert in the document. 

 Click Insert. Notice that a placeholder appears where information from the data record 

will eventually appear. 

 Repeat these steps each time we need to enter information from our data record. 

 

 Click Next: Preview your letters in the task pane once we have completed our letter. 

 Preview the letters to make sure the information from the data record appears correctly 

in the letter. 

 Click Next: Complete the merge. 

 Click Print to print the letters. 

 Click All. 

 Click OK in the Merge to Printer dialog box. 

 Click OK to send the letters to the printer. 

 

14.  Paragraph and Character Style 

Word provides several ways to achieve each of these effects in our document. We can easily change the 

paragraph and character style in Word document. For example, to format headings, We can select the 

text, apply bold formatting, and then apply a slightly larger font size than the size that we use for the 

body text. 

 

 
 



15. Macros 

Macros are advanced features that can speed up editing or formatting we may perform 

often in a Word document. They record sequences of menu selections that we choose so 

that a series of actions can be completed in one step. 

 

To record a Macro: 

 Click the View Tab on the Ribbon 

 Click Macros 

 Click Record Macro 

 

 

 Enter a name (without spaces) 

 Click whether we want it assigned to a button (on the Quick Access Toolbar) or the keyboard (a 

sequence of keys) 

 To assign the macro a button on the Quick Access Toolbar: 

 Click Button 

 Under the Customize Quick Access Toolbar, select the document for which we want the 

Macro available 



 

 

 Under Choose Commands:  Click the Macro that we are recording 

 Click Add 

 Click OK to begin Recording the Macro 

 Perform the actions we  want recorded in the Macro 

 Click on Macros 

 Click on Stop Recording Macros 

 

 To assign a macro button to a keyboard shortcut: 

 Click Keyboard 

 In the Press New Shortcut Key box, type the key sequence that we want and 

click Assign 



 
 

 Click Close to begin recording the Macro 

 Perform the actions we want recorded in the Macro 

 Click on Macros 

 Click on Stop Recording Macros 

 

15.1 Running a Macro 

Running a macro depends on whether it’s been added to the Quick Access Toolbar or if it’s been given a 

Keyboard Shortcut. 

 To run a Macro from the Quick Access Toolbar, simply click the Macro Icon 

 

 To run a Macro from the Keyboard shortcut, simply press the keys that we have programmed to 

run the Macro. 

 

Summary 

In this chapter we have discussed the most advanced features of Microsoft word software such as 

inserting tables, headers and footers, page numbers, hyperlink, managing footnotes and endnotes, 

references and cross-references, using word template,  table of contents, spell check, grammar and 

thesaurus, mail merge, setting paragraphs and character styles and recording macro.  

 

 

 

 



Links: 

 https://supportofficecom/en-us/article/Insert-or-create-a-table-de20e78c-ede3-4043-a9fb-27f0b73fb447  

 http://wwwwikihowcom/Add-a-Footnote-to-Microsoft-Word 

 https://supportofficecom/en-us/article/Insert-headers-and-footers-f22334fb-4455-4b18-9354-7c9c70c3b032 

 https://supportofficecom/en-us/article/Add-page-numbers-to-a-header-or-footer-46d6dfe5-f99b-40d8-8809-

be4808a291f4 

 https://supportofficecom/en-us/article/Add-page-numbers-9f366518-0500-4b45-903d-987d3827c007 

 http://wwwfgcuedu/support/office2007/word/referencesasp 

 https://supportofficecom/en-gb/article/Add-or-delete-captions-2dfedcf0-95b1-40e3-9674-96d0ee25faca 

 https://supportofficecom/en-us/article/Create-or-update-a-cross-reference-aa35c606-34e8-4c64-b6eb-

c6321d190645 

 https://supportofficecom/en-us/article/Create-format-or-delete-a-hyperlink-0c2f680d-5f61-48b9-9f6f-

894c6f3cab55https://supportofficecom/en-us/article/Create-a-template-86a1d089-5ae2-4d53-9042-1191bce57deb 

 http://wordprocessingaboutcom/od/microsoftword2007/a/crossreferenceshtm 

 https://supportofficecom/en-us/article/Create-a-table-of-contents-or-update-a-table-of-contents-eb275189-b93e-

4559-8dd9-c279457bfd72   

 http://www.gcflearnfree.org/word2007/23.3  

 http://www.fgcu.edu/support/office2007/word/macros.asp  


